Facebook
From parmjot, 7 Months ago, written in Plain Text.
Embed
Download Paste or View Raw
Hits: 49
  1. [ 86%] Building CXX object src/plugins/flatpak/CMakeFiles/flatpak.dir/flatpakresource.cpp.o
  2. /home/hexagon/.cache/yay/liri-appcenter-git/src/appcenter/src/plugins/flatpak/flatpakresource.cpp: In member function ‘virtual QUrl FlatpakResource::translateUrl() const’:
  3. /home/hexagon/.cache/yay/liri-appcenter-git/src/appcenter/src/plugins/flatpak/flatpakresource.cpp:169:48: error: ‘AppStream::Component::UrlTranslate’ is deprecated [-Werror=deprecated-declarations]
  4.   169 |     return m_appdata.url(AppStream::Component::UrlTranslate);
  5.       |                                                ^~~~~~~~~~~~
  6. In file included from /home/hexagon/.cache/yay/liri-appcenter-git/src/appcenter/src/plugins/flatpak/flatpakresource.h:15,
  7.                  from /home/hexagon/.cache/yay/liri-appcenter-git/src/appcenter/src/plugins/flatpak/flatpakbackend.h:15,
  8.                  from /home/hexagon/.cache/yay/liri-appcenter-git/src/appcenter/src/plugins/flatpak/flatpakplugin.h:10,
  9.                  from /home/hexagon/.cache/yay/liri-appcenter-git/src/appcenter/src/plugins/flatpak/flatpakresource.cpp:18:
  10. /usr/include/AppStreamQt/component.h:93:13: note: declared here
  11.    93 |             UrlTranslate   [[deprecated]] = UrlKindTranslate,
  12.       |             ^~~~~~~~~~~~
  13. /home/hexagon/.cache/yay/liri-appcenter-git/src/appcenter/src/plugins/flatpak/flatpakresource.cpp:169:48: error: ‘AppStream::Component::UrlTranslate’ is deprecated [-Werror=deprecated-declarations]
  14.   169 |     return m_appdata.url(AppStream::Component::UrlTranslate);
  15.       |                                                ^~~~~~~~~~~~
  16. In file included from /home/hexagon/.cache/yay/liri-appcenter-git/src/appcenter/src/plugins/flatpak/flatpakresource.h:15,
  17.                  from /home/hexagon/.cache/yay/liri-appcenter-git/src/appcenter/src/plugins/flatpak/flatpakbackend.h:15,
  18.                  from /home/hexagon/.cache/yay/liri-appcenter-git/src/appcenter/src/plugins/flatpak/flatpakplugin.h:10,
  19.                  from /home/hexagon/.cache/yay/liri-appcenter-git/src/appcenter/src/plugins/flatpak/flatpakresource.cpp:18:
  20. /usr/include/AppStreamQt/component.h:93:13: note: declared here
  21.    93 |             UrlTranslate   [[deprecated]] = UrlKindTranslate,
  22.       |             ^~~~~~~~~~~~
  23. cc1plus: all warnings being treated as errors
  24. make[2]: *** [src/plugins/flatpak/CMakeFiles/flatpak.dir/build.make:132: src/plugins/flatpak/CMakeFiles/flatpak.dir/flatpakresource.cpp.o] Error 1
  25. make[1]: *** [CMakeFiles/Makefile2:486: src/plugins/flatpak/CMakeFiles/flatpak.dir/all] Error 2
  26. make: *** [Makefile:136: all] Error 2
  27. ==> ERROR: A failure occurred in build().
  28.     Aborting...
  29.  -> error making: liri-appcenter-git
  30.  
captcha